Написать программу, которая вводит целые случайные числа в диапазоне от -10 до 10 с оператора random, затем выводит весь массив на экран и после этого выводит на экран количество чисел больших среднего арифметического. Программу нужно написать в паскале

Еккуш63шшк83оагш7гв Еккуш63шшк83оагш7гв    1   10.12.2020 15:20    1

Ответы
zelenskiy10000 zelenskiy10000  09.01.2021 15:24

Среднее арифметическое по условию не выводит.

program v1;

var a:array[0..30]of integer;  

i,n,sum:integer;

t:real;

begin

 sum:=0;

 writeln('Введите размерность матрицы: '); readln(n);

 randomize;

for i:=1 to n do a[i]:=random(20)-10;                            

write('Значение матрицы: ');                                      

for i:=1 to n do write(a[i]:5); writeln;  

for i:=1 to n do begin  

sum:=sum+a[i];

t:= sum/n ;

 end;

 for i:=1 to N do if a[i]>t then write(a[i]:3);

   writeln;

end.


Написать программу, которая вводит целые случайные числа в диапазоне от -10 до 10 с оператора random
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика