Написать программу суммирующую числа до тех пор пока не будет введён "0".
Входные данные:
1 2 3 0
Выходные данные:
6
2. Написать программу поиска НОД (Наибольший Общий Делитель) двух чисел.
Входные данные:
170 42
Выходные данные:
2

ksetitaafrgb ksetitaafrgb    2   11.05.2020 11:15    1

Ответы
liliyaabramova1 liliyaabramova1  14.10.2020 13:01

1)

program g;

var

a, b, c, d:integer;

begin

Readln(a, b, c, d) ;

begin

if a = 0 then

Writeln('0') end ;

begin

if b = 0 then

Writeln(a) end ;

begin

if c = 0 then

Writeln(a + b) end ;

begin

if d = 0 then

Writeln(a + b + c) end ;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика