Написать программу, которая в заданном одномерном массиве размерности n меняет местами соседние элементы, стоящие на чётных местах, с соседними элементами, стоящими на нечётных местах.

MFINN23 MFINN23    2   21.05.2019 16:30    9

Ответы
lyazkaiman0309 lyazkaiman0309  16.06.2020 11:19

var a:array[1..10] of integer;
i,tmp:integer;

begin  cls;
 for i:=1 to 10 do a[i]:=i;
 
 for i:=1 to 10 do
 begin
 if i mod 2 = 1 then
 begin
 tmp:=a[i];
 a[i]:=a[i+1];
 a[i+1]:=tmp;
 end;
 
 end;
for i:=1 to 10 do
write(a[i], ' ');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика