Написать программу которая содержит подпрограмму-функцию которая вычисляет кол-во положительных элементов одномерного массива 10 компонентов вещественного типа. (решить на базе pascal 7.0)

Lizzzas Lizzzas    3   22.07.2019 14:50    2

Ответы
UltraTwItTeR UltraTwItTeR  15.09.2020 21:58
Const
  n = 10;

type
  ty = array[1..n] of real;

var
  ar: ty;
  i: integer;

function re(ar: ty): integer;
var
  i, k: integer;
begin
  k := 0;
  for i := 1 to n do
    if ar[i] > 0 then inc(k);
  re := k;
end;

begin
  for i := 1 to n do
    readln(ar[i]);
  writeln(re(ar));
end.

Пример ввода:
-1
0
1
1
1
1
1
1
1
-2
Пример вывода:
7
ПОКАЗАТЬ ОТВЕТЫ
Юлия7791 Юлия7791  15.09.2020 21:58
Type tMas = array[1..10] of Real;
Var m : tMas;
  i : Byte;
Function OddFunc(b : tMas) : Byte;
Var j,n : Byte;
Begin
  n:=0;
  For j:=1 to 10 do If b[j]>0 then Inc(n);
  OddFunc:=n;
end;
Begin
  For i:=1 to 10 do
  Begin
    m[i]:=-100+Random(200);
    Write(m[i],' ');
  end;
  Writeln;
  Writeln(OddFunc(m));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика