tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу, которая
Написать программу, которая считывает два числа a и б, и выдает б-тую цифру числа а! например: число 192345(а) число б = 3, тогда третяя цифра в числе 192345 равняется 2
камкозавра
3 06.07.2019 08:50
2
Ответы
ленура21
29.07.2020 16:16
#include <stdio.h>
int main()
{
int a,b,e,d;
a=192345; //Число
e=5; //Номер цифры
int c[1000000];
d=0;
while(a>0)
{
b=a%10;
d++;
c[d]=b;
a/=10;
}
for(int i=d;i>0;i--){
if((d-i+1)==e)printf("Цифра %d\n",c[i]); //Вывод искомой цифры
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
оопда
18.02.2020 23:29
Построить блок схему и найти корень квадратный из числа даю все что есть...
Vova50915091
18.02.2020 23:28
Задан двумерный массив С[n][m] (1 p, m 20). Найдите наибольшийэлемент в этом массиве....
235www
18.02.2020 23:28
мне нужно здать завтра, сделайте, заранее...
mrden3333
18.02.2020 23:28
СОСТАВЬТЕ СЛОВЕСНЫЙ АЛГОРИТМ РИСОВАНИЯ ЛИНИИ В ВИДЕ БЛОК СХЕМЫ ОЧЕНЬ...
одиннадцать1
26.07.2019 06:30
Сколько секунд потребуется модему, сообщения со скоростью 14400 бит в секунду, чтобы передать цветное растровое изображение размером 800 на 600 пикселей, при условии,...
arsenijcurikov
08.06.2019 19:10
1)напишите программу, которая считает количество четных цифр введенного числа 2) напишите программу, которая вводит с клавиатуры натуральное число n и определяет...
dashko4etckowa
08.06.2019 19:10
Какое минимальное основание может иметь система счисления, если в ней записано число 11? число 99? и если не сложно, то объясните почему...
MarijaKitty
08.06.2019 19:10
Имеется исполнитель кузнечик, который живет на числовой оси. система команд кузнечика: вперед n (кузнечик прыгает вперед на n единиц); назад m (кузнечик прыгает...
sasipomidorp01sct
27.08.2019 20:40
Воднородном массиве, состаящем из n вещественных элементов, найти максимальный по модулю элемент массива....
Торт123
27.08.2019 20:40
Написать программу решения уравнения ax(в 3 степени ) + bx=0 для произвольных а, в, значения которых вводятся с клавиатуры...
Популярные вопросы
Выполните действия (b^2c^3-2a^2)(b^2c^3+2a^2)...
1
Разложить на множители b(3b+1)-2(3b+1)...
3
Составить краткую к . на завод отправлено 3600 т угля в вагонах,по...
3
Перечислите все внешнеполитические события с 1955 по 1964 г....
3
Приключения гекльберри финна ,самый захватывающий момент...
3
Во сколько раз возрастет скорость реакции при повышении температуры...
1
Как можно перепестить курсор к обнаруженной ошибке...
1
Напишите сочинение на языке, на тему why do conflicts happen...
1
2: 00 2: 05 2: 10 2: 15 2: 20 2: 25 2: 30 2: 35 2: 40 2: 45...
3
Разложите на множители. 1) x²-81 2) y²-6y+9 3) 16x²-49 4) 9a²+30ab+25b²...
2
int main()
{
int a,b,e,d;
a=192345; //Число
e=5; //Номер цифры
int c[1000000];
d=0;
while(a>0)
{
b=a%10;
d++;
c[d]=b;
a/=10;
}
for(int i=d;i>0;i--){
if((d-i+1)==e)printf("Цифра %d\n",c[i]); //Вывод искомой цифры
}
return 0;
}