Написать программу, которая перемещает все нули в конец списка. Ваша задача — изменить список так, что бы нули оказались в конце списка.
Порядок ненулевых чисел должен сохранится.
Пример:
[0, 1, 0, 3, 12] -> [1, 3, 12, 0, 0]
[0] -> [0]
[1, 0, 3, 0, 0, 0, 5] -> [1, 3, 5, 0, 0, 0, 0]
[9, 0, 7, 31, 0, 45, 0, 45, 0, 45, 0, 0, 96, 0] -> [9, 7, 31, 45, 45, 45, 96, 0, 0, 0, 0, 0, 0, 0]

NekitFe NekitFe    1   19.07.2022 04:15    1

Ответы
Tamilla19 Tamilla19  19.07.2022 06:00

i = []

for a in input().split():

   i.append(int(a))

i.sort(key=lambda x: x==0)

print(i)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика