Написать программу которая классифицирует треугольники равнобедренный, равносторонний,прямоугольный,если даны 3 стороны треугольника.

Djama1234 Djama1234    3   07.06.2019 05:30    4

Ответы
Доринэ Доринэ  07.07.2020 01:39
Var a,b,c:real;
begin
writeln('Введите 1 сторону треугольника');
readln(a);
writeln('Введите 2 сторону треугольника');
readln(b);
writeln('Введите 3 сторону треугольника');
readln(c);
if (a=b)and(b=c) then writeln('Равносторонний треугольник')
else if (a=b) or(b=c)or(a=c) then writeln('Равнобедренный треугольник')
else if (sqr(a)=sqr(b)+sqr(c))or(sqr(b)=sqr(a)+sqr(c))or(sqr(c)=sqr(b)+sqr(a)) then writeln('Прямоугольный треугольник')
else writeln('Обычный треугольник');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика