Написать программу, которая из случайно сформированного
одномерного массива размерности 10 выводит только те
элементы, значения которых принадлежат отрезку [-6; 30].
Для заполнения массива использованы случайные числа от -
10 до 50.

dianakokorina91 dianakokorina91    1   18.04.2020 18:54    6

Ответы
nipogodin nipogodin  13.10.2020 11:32

Program Rnd2020;

type rnd_array = array [1..10] of integer;

var

  i:1..10;

 k:integer;

a: rnd_array;

v:integer;

begin

       (* инициализируем генератор случайных чисел *)

      randomize;

    for i:=1 to 10 do

    a[i]:=rand(41)+10;

    for i:=1 to 10 do

   begin

            v:=a[i];

            if ((v>=  -6) and (v<=30)) then

              writeln(v);

    end;

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика