Написать программу, которая из слова «информатика» получает и выводит на экран слово «марка».

Подсказка к решению: Слова марка состоит из трех кусочков которые мы можем получить из слова «информатика»: ма, р, ка. Надо получит эти три части с команды copy и затем сложить их.

ма – copy (a,6,2) (кусочек берем из слова а= «информатика», буква м стоит на 6 месте, в кусочке 2 буквы)

Program slova;

Var a, b: string;

Begin a:=’информатика’;

b:= copy (a,6,2) + copy (a,5,1) + copy (a,10,2);

WriteLn (b);

End.

Tashkentskiy Tashkentskiy    3   16.04.2020 20:22    3

Ответы
тупой810 тупой810  13.10.2020 09:45

По идеи, строки в Паскале являются одномерными массивами, легче просто присвоить второй строке символы из первой строки:

b:= a[6]+a[2] ...

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика