Написать программу, которая генерирует 10 случайных чисел в диапозоне от 1 до 10, выводит эти числа на экран и вычисляет их среднее арифметическое

алик143 алик143    2   22.05.2019 08:20    15

Ответы
lolgg2 lolgg2  17.06.2020 12:22

PROGRAM ThreeSequences(INPUT, OUTPUT);
VAR
 Number: ARRAY[1 .. 3, 1 .. 10] OF INTEGER;
 ArithmeticAverage: ARRAY[1 .. 3] OF INTEGER;
 I, J: INTEGER;  
BEGIN {ThreeSequences}
 Randomize;
 {Генерирует 3 последовательности по 10 случайных чисел}
 FOR I := 1 TO 3
 DO
   FOR J := 1 TO 10
   DO
     Number[I][J] := Random(10) + 1;
 {Выводит последовательности и считает среднее арифметическое}
 FOR I := 1 TO 3
 DO
   BEGIN
     WRITE('Sequences: ');
     ArithmeticAverage[I] := 0;
     FOR J := 1 TO 10
     DO
       BEGIN
         WRITE(Number[I][J]:3);
         {Складывает все числа последовательности}
         ArithmeticAverage[I] := ArithmeticAverage[I] + Number[I][J];
       END;
     WRITELN;
     {Делит на количество чисел последовательности}
     ArithmeticAverage[I] := ArithmeticAverage[I] DIV J;
     WRITELN('ArithmeticAverage: ', ArithmeticAverage[I]);
   END;
END. {ThreeSequences}

ПОКАЗАТЬ ОТВЕТЫ
gasimovaa44 gasimovaa44  17.06.2020 12:22

uses crt; 

var

a,k,s:shortint;

sr:real;

begin

clrscr;

randomize;

repeat

a:=random(10)+1;

write (a:3);

k:=k+1;

s:=s+a;

until k=10;

sr:=s/k;

writeln; 

writeln ('Srednee: ',sr:0:4);

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика