Написать программу, которая бы по введенному номеру времени года(1-зима 2-весна 3-лето 4-осень) выдавала соответствующие этому времени года месяцы, количество дней в каждом из месяцев. только на уровне 8 класса !

Uliana1pa Uliana1pa    3   17.05.2019 11:50    29

Ответы
1406052005 1406052005  30.09.2020 19:11

var m:integer;

begin

read(m);

if m=1 then

begin

writeln(' Декабрь (31), январь (31) , февраль (28, 29) ');

end;

if m=2 then

begin

writeln(' Март(31), апрель(30), май(31)');

end;

if m=3 then

begin

writeln(' июнь(30), июль (31), август ( 31)');

end;

if m=4 then

begin

writeln(' сентябрь(31), октябрь (30), ноябрь (31)');

end;

end.

 

если, количество дней не такое, подправишь.

ПОКАЗАТЬ ОТВЕТЫ
Kloloko Kloloko  30.09.2020 19:11

Program done;
var mlr:integer;
begin
writeln('Введите число времени года');
readln(mlr);
case mlr of
1: writeln('Время года: Зима. ' , ' Месяца: Декабрь, Январь, Февраль. ' , ' Количество дней в Январе: 31 | Феврале: 30 | Декабре: 31.');
2: writeln('Время года: Весна. ' , ' Месяца: Март, Апрель, Май. ' , ' Количество дней в Марте: 31 | Апреле: 30 | Мае: 31.');
3: writeln('Время года: Лето. ' , ' Месяца: Июнь, Июль, Август. ' , ' Количество дней в Июне: 30 | Июле: 31 | Августе: 31.');
4: writeln('Время года: Осень. ' , ' Месяца: Сентябрь, Октябрь, Ноябрь. ' , ' Количество дней в Июне: 30 | Июле: 31 | Августе: 30.');
else writeln('Данного времени года не существует!');

end;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика