Надо. написать программу с цикла, которая позволяет ввести с клавиатуры последовательность из трех дробных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности. ниже представлен рекомендуемый вид экрана во время работы программы: *обработка последовательности дробных чисел* после ввода каждого числа нажмите - > 12.3 введено чисел: 1 среднее арифметическое: 12.30 - > 15 введено чисел: 2 среднее арифметическое: 13.65 - > 10 введено чисел: 3 среднее арифметическое: 12.43

666Default666 666Default666    3   14.03.2019 17:40    3

Ответы
07Zarina1111 07Zarina1111  25.05.2020 08:38

var a: array[1..3] of real;

x: real;
i: shortint;
begin
writeln('После ввода каждого числа нажмите <Enter>');
a[1]:=0; a[2]:=0; a[3]:=0;
for i:=1 to 3 do begin
write('->');
readln(a[i]);
x := ((a[1]+a[2]+a[3])/i)*100;
x := round(x);
x := x/100;
writeln('Введено чисел: ',i,' Среднее арифметическое: ',x);
end;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика