Написать программу,которая: 1. создает вещественный массив из 8 элементов; 2. заполняет массив элементами прогрессии с a0=1 и q=0.5; 3. подсчитывает количество элементов массива, меньших 0.1 4. присваивает симметрично значения первых 4 элементов массива значениям последних 4 элементов. после второго и четвертого действия вывести элементы массива в столбик.

jeniakovaleva56 jeniakovaleva56    3   20.07.2019 22:30    1

Ответы
sofi190 sofi190  31.07.2020 17:04
// PascalABC.NET 3.1, сборка 1184 от 02.03.2016
begin
  var a:=SeqGen(8,1.0,i->i*0.5).ToArray; // 1 и 2
  a.Println(NewLine); // вывод
  Writeln('Меньших 0.1: ',a.Count(x->x<0.1)); // 3
  for var i:=0 to 3 do Swap(a[i],a[7-i]); // 4
  a.Println(NewLine); // вывод
end.

Тестовое решение:
1
0.5
0.25
0.125
0.0625
0.03125
0.015625
0.0078125
Меньших 0.1: 4
0.0078125
0.015625
0.03125
0.0625
0.125
0.25
0.5
1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика