Написать программу,инвертирующее байтовое число. Т.е. число 25 превратит в -25. Число -127 превратит в 127.

1232955 1232955    3   14.05.2020 17:51    7

Ответы
yulyatimonen yulyatimonen  14.10.2020 19:00

С++

#include <iostream>

int main() {

 char a = 25, b = -127;

 a = ~a;

 a++;

 b = ~b;

 b++;  

 printf("%d %d", a, b);

}

Версия с вводом числа (терминал)

#include <iostream>

int main() {

 char a;

 std::cout << "Type your num: ";

 std::cin >> a;

 a = ~a;

 a++;

 printf("Your inverse num: %d", a);

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика