Написать программу для вывода на экран минимально возможного набора купюр для выдачи сдачи кассиром покупателю с одной тысячи рублей, если покупатель должен заплатить n рублей

QuAtTro271 QuAtTro271    1   17.07.2019 19:10    4

Ответы
wur1k wur1k  07.08.2020 08:48
//PascalABC.NET Версия 3.0 Сборка 1150
var n:integer;
begin
  writeln('Сколько стоит товар?');
  readln(n);
  n:=1000-n;
  writeln('Сдача ',n,' рублей. Нужны купюры:');
  writeln(n div 500, ' по 500 рублей, ', (n-(n div 500)*500)div 100, ' по 100 рублей, ', (n mod 100) div 50, ' по 50 рублей, ', (n-(n div 50)*50) div 10,' по 10 рублей, и ещё ', n mod 10, ' рублей мелочью.');
end.

Результат работы:
Сколько стоит товар?
324
Сдача 676 рублей.
Нужны купюры:
1 по 500 рублей, 1 по 100 рублей, 1 по 50 рублей, 2 по 10 рублей, и ещё 6 рублей мелочью.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика