Написать программу для вычисления суммы числел от a до b (где a< =b) указание: переменная, которая будет накапливать сумму в начале должна быть равна нулю

tatiana342 tatiana342    3   20.09.2019 01:50    0

Ответы
flow789456587 flow789456587  08.10.2020 03:35
1. Современное решение

// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2('Введите через пробел a и b:');
  Writeln('S=',Range(a,b).Sum)
end.

Пример
Введите через пробел a и b: 5 18
S=161

2. К сожалению, все еще часто типичный для школы вариант

var
  a,b,i,s:integer;
 
begin
  Write('Введите через пробел a и b: ');
  Read(a,b);
  s:=0;
  for i:=a to b do
    s:=s+i;
  Writeln('S=',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика