написать программу для С++ Дан массив из n элементов. Найти сумму элементов, стоящих на нечетных
местах и вывести их на экран. Затем вставить их в новый массив умножив на
n, и удалить последний элемент.​

rje87391 rje87391    3   17.11.2020 08:16    8

Ответы
ninachka1977 ninachka1977  17.12.2020 08:18

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

using namespace std;

int main() {

vector<int> arr;

int n;

cout << "n: ";

cin >> n;

srand(time(0));

long long sum = 0;

vector<long int> multi;

for(int i = 0; i<10; ++i) { //  тут поменять чтобы изменить колво чисел

arr.push_back(rand());

if(i%2!=0) {

sum+=arr[arr.size()-1];

cout << arr[i] << " ";

multi.push_back(arr[arr.size()-1]*n);

}

}

cout << endl << "Multi: ";

for(int i = 0; i<multi.size(); ++i) {

cout << multi[i] << " ";

}

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика