tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу для подсчёта
Написать программу для подсчёта количества вхождений подстроки в строку. (язык с++)
aselznala2004
2 15.09.2019 04:40
9
Ответы
ИзмМалика
07.10.2020 16:10
#include <iostream>
#include <string>
using namespace std;
int main()
{
string str, substr;
cout << "String = "; getline(cin, str);
cout << "Substring = "; cin >> substr;
int cnt = 0;
for(int i = 0; i < str.length(); ++i)
if(str[i] == substr[0])
if(str.substr(i, substr.length()) == substr)
{
++cnt;
i += substr.length() - 1;
}
cout << cnt;
return 0;
}
//
Пример:
String = test testHelloWorld testtest1243test
Substring = test
5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Почтиматематик2894
21.05.2019 10:51
Что такое ссылка.информатика...
k03a12345
21.05.2019 10:50
98 переаедите с паскаля на питон program zadbl; uses crt; var a,b,c,i,s: integer; m: array[1..30] of integer; begin s: =-1; for i: =1 to 30 do begin m[i]: =random(100); write(m[i]:...
Níkiskastarling28
21.05.2019 10:49
Вывести 15 первых простых чисел, в котррых присутсвует n....
baskaqusar
21.05.2019 10:49
Укати на флешке осталось 150 мб свободного пространства. хватит ли его для записи 12 аудиозаписей, если средняя продолжительность 3,5 минуты, разрешение звука 16 бит, а частота 20...
Kakation
21.05.2019 10:49
98 переведите с паскаля на питон const n = 30; var a: array[1..n] of integer; i,smax,ismax: integer; begin randomize; write( исходный массив: ); for i: = 1 to n do begin a[i]: =random(n);...
Dmitry81
21.05.2019 10:48
За 4 минуты были переданы 4 файла по 900 килобайт чему равна скорость перелачи данных через данное соединение ? значение скорости представьте в килобитах/сек...
rrrr10
21.05.2019 12:00
Даны натуральное число n и целые числа a1, . получить: а)а1-а2+; б)а1+аn; в)а1-а2. , , в паскале. ваша нужна; *...
kristina17102004
21.05.2019 12:00
Сwhile напишите программу определения суммы всех нечетных чисел в диапазоне от 1 до 99 включительно....
dyba2003
21.05.2019 12:00
Вычислите сумму квадратов n четных натуральных чисел....
eandrukova567
26.04.2020 23:55
Используя цикл составить программу нахождения сумма 10 чисел.Составить программу которая вводит число и выводит его увеличенным на 2. Количество введенных чисел 5на python...
Популярные вопросы
Какая масса углекислого газа выделиться при сгорании 156л метана при н.у...
3
Вкоробке лежат 16 шаров — белых, красных и черных, причем белых в 8 раз больше,...
2
1)сделать в ионном виде cucl2- cu(oh)2- cu(no3)2 2)по овр pbs+hno3- s+pb(no3)2+no3+h2o...
2
Положительные герои из сказки аик кериб...
1
Каким чувством наполнено сцена прибытием суок в сказки три толстяка...
2
Построить прямоугольник,половина площади равна 10 сантиметров квадратных...
3
Четверостишье со словами мечта цель желание фантазия...
2
Составить равенства и неравенства,используя вырожения: 1×6,0÷9,7÷7,1×3,8×0,6÷2,3×2,12÷12.?...
2
Плоскость,параллельная основаниям ad и bc трапеции abcd,пересекает стороны ab...
3
Сыну 13 лет, его отцу 47. через сколько лет отец будет старше сына в 3 раза. из...
1
#include <string>
using namespace std;
int main()
{
string str, substr;
cout << "String = "; getline(cin, str);
cout << "Substring = "; cin >> substr;
int cnt = 0;
for(int i = 0; i < str.length(); ++i)
if(str[i] == substr[0])
if(str.substr(i, substr.length()) == substr)
{
++cnt;
i += substr.length() - 1;
}
cout << cnt;
return 0;
}
//
Пример:
String = test testHelloWorld testtest1243test
Substring = test
5