Написать программу для паскаль через оператор case. для целого числа k от 1 до 99 напечаать фразу "мне k лет", учитывая при этом что при вводе некоторых значений k слово "лет" надо заменить на слово "год" или "года".

Niklosh Niklosh    1   29.06.2019 04:10    2

Ответы
busiginanst99 busiginanst99  23.07.2020 08:03
Program p1;
Var a:integer;
Begin
  Write('Введите возраст: ');
  Readln(a);
  Case a of
    11..14:Write('Мне ',a,' лет');
    else
    Case a mod 10 of
      1:Write('Мне ',a,' год');
      2..4:Write('Мне ',a,' года');
      else Write('Мне ',a,' лет');
    End;
  End;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика