Написать программу для pascal: выиснить является ли заданное число совершенным?

ilya3666664 ilya3666664    3   31.03.2019 13:30    4

Ответы
xeniyaforevermailru xeniyaforevermailru  27.05.2020 22:43

Program Pr1;
uses crt;
var i,n,a:integer;
Begin
clrscr;
readln(n);
i:=1; a:=0;
while i<=n do begin
if (n mod i=0) and (i<>n) then a:=a+i;
inc(i);
end;
if a=n then writeln('YES')
else writeln('No');
end.

ПОКАЗАТЬ ОТВЕТЫ
pozhidaevad pozhidaevad  27.05.2020 22:43

uses
SysUtils;

var
n,m,i:integer;
begin
readln(n);
m:=0;
for i := 1 to n-1 do
if m > n then break else
if (n mod i = 0) then m:=m+i;
if m=n then writeln('Yes') else
writeln('No');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика