Написать программу для отыскания max(min(a,b), min(c, не используя сложные логические условия и вложенные ветвления. числа a,b,c,d - целые. протестировать программу для следующих исходных данных: а) a=4 b=5 c=6 d=9 б) a=2 b=1 c=6 d=9 в) a=2 b=1 c=8 d=4 г) a=12 b=1 c=6 d=9

mayte mayte    3   06.06.2019 02:20    15

Ответы
СинийГраф СинийГраф  06.07.2020 11:12
Var a,b,c,d,m1,m2,max:integer;
begin
write('Введите a,b,c,d: ');
readln(a,b,c,d);
if a<b then m1:=a else m1:=b;
if c<d then m2:=c else m2:=d;
if m1<m2 then max:=m2 else max:=m1;
writeln('MAX=',max)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика