Написать программу: дано трехзначное число. найти сумму цифр числа и определить является ли она четным числом.

nikkun80 nikkun80    1   13.09.2019 19:50    2

Ответы
popoposa popoposa  26.08.2020 20:27
//Pascal
var a, sum: integer;
begin
write('Введите число:'); readln(a);
  while a <> 0 do
  begin
    sum := sum + (a mod 10);
    a := a div 10;
  end;
  writeln('Сумма цифр = ', sum);
  if sum mod 2 = 0 then writeln('Сумма четная')
  else writeln('Сумма нечетная')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика