Написать блок-схему и программу для паскаль! написать программу решения следующей : определить, является ли «счастливым» трамвайный билет с шестизначным номером («счастливым» считается билет, у которого сумма первых трёх чисел совпадает с суммой трёх последних чисел). ответ вывести на печать.

максим1714 максим1714    1   22.07.2019 03:40    18

Ответы
Kara2006kara Kara2006kara  03.10.2020 10:24
Программа:
var n,a1,a2,s1,s2:integer;
begin
write('n = '); readln(n);
a1:=n div 1000;
s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);
a2:=n mod 1000;
s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);
if s1=s2 then writeln('Билет счастливый')
          else writeln('Билет не счастливый')
end.
Пример:
n = 123231
Билет счастливый

Блок-схема - в прилагаемом файле.
Написать блок-схему и программу для паскаль! написать программу решения следующей : определить, явля
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика