НАДО написать оператор Repeat-Untill)

программа загадывает случайное число в диапазоне от 1 до 100.Написать программу,позволяющая пользователю угадать заданное число за неизвестное количество попыток. если пользователь будет вводить число,меньше загаданного,тогда появится на экране подсказка "больше",и наоборот-если число будет больше загаданного появляется подсказка "меньше".Если он угадывает число за количество попыток меньше 7,тогда появляется надпись "молодец",если больше 7 - "плохо"

Madinauakhitova Madinauakhitova    2   07.05.2020 19:48    6

Ответы
D1999d3004 D1999d3004  14.10.2020 10:21

var a,b,c: real;

begin

 c:=0;

 a:=random (100);  

 repeat  readln(b); if b<a then begin writeln('больше') ;c:=c+1;end else if b>a then begin writeln('меньше') ;c:=c+1  end until b=a;

 if c<7 then writeln('молодец') else writeln('плохо')

 end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика