Надо, . 1. составьте программу вычисления суммы чисел в диапазоне от 13 до 113. 13+14+15+ +113 2. составьте программу вычисления суммы чисел кратных 5 в диапазоне от 5 до 105. 3. составьте программу, которая выводит на экран числа кратные 2 и 7 в диапазоне от 2 до 120.

даша89194733164 даша89194733164    1   18.07.2019 19:40    23

Ответы
y4enik5 y4enik5  07.08.2020 09:42
Var 
b,i:integer;
Begin  for i:= 13 to 113 do   
b:=b+i; 
Writeln('Сумма чисел в диапазоне от 13 до 113 = ',b); 
b:=0; 
for i:= 5 to 105 do   
if (i mod 5) = 0 then      b:=b+i; 
Writeln('Сумма чисел кратных 5 в диапазоне от 5 до 105 = ',b);   
b:=0; 
Writeln('Числа кратные и 2 и 7 в диапазоне от 2 до 120 );   
for i:= 2 to 120 do   
if ((i mod  2) = 0) and ((i mod 7) = 0) then write(i,' '); 
end.  

Всё просто. Если разделять на программы, то каждый новый цикл это другая программа.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика