На языке программирования pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. число делится только на 1 и на само себя без остатка) (число 354)

Kamilla0707 Kamilla0707    3   26.09.2019 23:20    4

Ответы
sheykinayulya sheykinayulya  27.08.2020 07:51

function isPrime(n:integer):boolean;

var res:boolean;

i:integer;

begin

if n>1 then res:=true

else res:=false;

for i:=2 to n div 2 do

if n mod i = 0 then

begin

res:=false;

break;

end;

isPrime:=res;

end;

var n:integer;

begin

writeln('введите целое число: n = ');

readln(n);

write(isPrime(n));

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика