На языке Паскаль составить программу для решения задач. класс в составе 25 чел. сдал экзамен по математике. необходимо внести за результаты по экзамену, посчитать средний бал, посчитать кол-во "4" и"5" вместе. кол-во "3", а вместе кол-во "2" и"1" решите

qq302894 qq302894    2   13.12.2021 13:03    2

Ответы
AlisaSkun3 AlisaSkun3  01.02.2022 22:36

Pascal

const  

  n=25;

var

 a:array[1..n] of integer;

 i, s0, s1, s2, s3 : integer;

begin

 randomize;

 s0:=0; s1:=0; s2:=0; s3:=0;

 for i:=1 to N do begin

   a[i]:=random(5)+1; (*если хотим ввести случайные оценки*)

//    readln(a[i]);  (*если хотим ввести оценки сами*)

   s0:=s0+a[i];

   case a[i] of

     4,5: inc(s1);

     3: inc(s2);

     1,2: inc(s3);

   end;

 end;

 writeln(a);

 writeln('Средний бал =', s0/n);

 writeln('Кол-во 4 и 5 =', s1);

 writeln('Кол-во 3 =', s2);

 writeln('Кол-во 2 и 1 =', s3);

end.


На языке Паскаль составить программу для решения задач. класс в составе 25 чел. сдал экзамен по мате
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика