На вход программе подаётся последовательность символов, заканчивающаяся точкой. требуется написать программу, которая определяет, есть ли в этой последовательности цифры, и выводит наибольшее число, которое можно составить из этих цифр. ведущих нулей быть не должно, за исключением одного нуля. если числа нет, выводится сообщение 'no', если число есть - 'да' и в следующей строке искомое число. например, если исходная последовательность была такая: day 10, mice 8: "year" 7 is a mistake 91. то результат должен быть следующий: да 987110

Angelina5353 Angelina5353    1   29.08.2019 08:50    21

Ответы
matumaxim matumaxim  06.10.2020 02:32
Begin
  var s := readstring();
   if(s.Any(x -> x.isDigit)) then
   begin
  if(s.Any(x->x in['1'..'9'])) then
  s.Where(x -> x.IsDigit).OrderByDescending(x -> x).Println
  else
  write(0);
  end
  else
writeln('No');
 end.
ПОКАЗАТЬ ОТВЕТЫ
m3rry1 m3rry1  06.10.2020 02:32
Var
   A:array['0'..'9'] of longint;
   C:char;
   i:integer;
Begin
For C:= '0' to '9' do A[C]:=0;
Repeat
Read(C);
if C in['0'..'9'] then A[C]:=A[C]+1;
Until C = '.';
if (A['1']=0)and(A['2']=0)and(A['3']=0)and(A['4']=0)and(A['5']=0)and(A['6']=0)and(A['7']=0)and(A['8']=0)and(A['9']=0) then
   if A['0']=0 then Write('no')
   else
      Begin
      WriteLn('Да');
      WriteLn(0);
      End
else
   Begin
   WriteLn('Да');
   For C:='9' downto '0' do
       For i:= 1 to A[C] do
           Write(C)
   End
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика