На си написать.
напишите программу вывода из файла первую и последнюю строки.
с объяснением )
и объясните как выводить любую строку.
с наступающим

Даша1707 Даша1707    2   25.12.2019 20:14    2

Ответы
krusher77 krusher77  10.10.2020 23:18

#include "stdio.h"

//Указатель на файл

FILE * pFile;

//Размер файла

int size;

//Буффер

char  buffer[160];

//Число считанных байт

size_t result;

if(pFile)

{

//Получаем размер файла

fseek (pFile, 0, SEEK_END);   // non-portable

size=ftell (pFile);

//Читаем первые 80 символов

fseek (pFile, 0, SEEK_SET);   // non-portable

result = fread (buffer,1,80,pFile);

 //Читаем вторые 80 символов

fseek (pFile, (size-80), SEEK_SET);   // non-portable

result = fread (&buffer[80],1,80,pFile);

 //Выводим результат

printf ("String",buffer,80);

fclose ( pFile);

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика