На с++ напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105

Kashakom04 Kashakom04    3   20.09.2019 10:10    9

Ответы
stydent65 stydent65  08.10.2020 04:24
#include <iostream>#include <cstdlib>using namespace std;
int main(){    int a, b, c = 0;    cin >> a >> b;    if (abs(a) > abs(b))        swap (a, b);    for (int i = 0; i < abs(a); i++)    {        if ((a >= 0 && b >= 0) || (a < 0 && b < 0))            c += abs(b);        else            c -= abs(b);    }    cout << c;    return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика