tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Найти среднне арифметическое
Найти среднне арифметическое элементов массива, расположенных после первого положительного элемента массива
MashaFox25
1 16.09.2019 16:30
2
Ответы
Seref
07.10.2020 20:05
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln(a[a.FindIndex(x->x>0)+1:].Average)
end.
Пример
n= 13
-7 32 -26 39 27 12 -15 -27 -20 39 -7 29 2
4.81818181818182
ПОКАЗАТЬ ОТВЕТЫ
makon3
07.10.2020 20:05
На C++ если надо
#include <iostream>using namespace std;int main(){ float mas[9]={-5,-1,2,3,-1,6,1,-1}; float sum=0; bool a=false; int counter=0; for(int i=0;i<8;i++){ if(mas[i]>0&&!a){ a=true; i++; } if(a){ cout<<mas[i]<<endl; sum+=mas[i]; counter++; } } cout<<sum/counter<<endl; return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
anastasia559
11.07.2019 10:40
Напишите программу анализа значений больного за сутки определите максимальное и минимальное значения, среднее арифметическое замеры температуры проводят шесть раз...
Никита111116644
24.04.2020 14:51
1. Составить программу: Даны x, y. Если x+y 0 то P := x2+y2 . Записать программу в тетрадь. 2. Составить программу: Даны a, b. Если a-b 0 то X := a2+b. Записать программу...
DrozZzD
24.04.2020 14:51
Для хранения растрового изображения размером 367×367 пикселей отвели 32 КБ памяти. Каково максимально возможное число цветов в палитре изображения?...
лыл3
24.04.2020 14:51
Напишіть програму ,яка запитує вік школяра і визначає,у якій ланці він навчається: початкова школа (1-4класи), основна (5-9класи) або старша (10-11класи)...
Tomokl
24.04.2020 14:51
Алгоритм это☝️За правильный ответ ...
kostan555ua
24.04.2020 14:51
с задачей по информатике Для записи текста использовался 256-символьный алфавит.Каждая страница содержит 30 строк по 70 символов в строка.Какой объем информации содержат...
Foret228
24.04.2020 14:51
Не была ни на одной лекции, теперь мучаюсь на дистанционке. Сдать нужно сегодня...
nadya5745
24.04.2020 14:51
У вас сеть класса С, вы выбрали маску подсети 255.255.255.248. Сколько подсетей и хостов вы получите?...
LJкрасотка2007
24.04.2020 14:51
На языке программирования Python составить программу, которая вычисляет произведение первых восьми натуральных чисел, кратных семи. Очень жду ответ,заранее благодарю!...
stasiko1
24.04.2020 14:50
Кегль измеряется в пунктах.Чему равен 1 пункт?...
Популярные вопросы
До якої групи онкогенних факторів належить іонізуюче випромінювання...
3
. Сын Жанибек хана, ему принадлежит центральное место в укреплении...
3
Дайте ответ с пояснением Макроэкономика) 3. Рассмотрим следующую...
3
Задание 3. Прочитайте эти рассказы или отрывки из рассказов (стр....
1
1 .Фізіологічний розчин - це 0,9% розчин натрій хлориду NaCl у...
1
Поясніть як реалізовувалась оборонна функція в будівництві храмів...
1
Впиши недостающие слова в ячейки. 1. В зависимости от выделяются...
2
3. Назвіть прізвища ви-датних науковців-засновників імунології....
3
Визнач час дієслів ( теп. ч: мин. ч: майб. ч:) Співають, защебече,...
2
Хто є автором повісті «Альпійська балада»?...
2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln(a[a.FindIndex(x->x>0)+1:].Average)
end.
Пример
n= 13
-7 32 -26 39 27 12 -15 -27 -20 39 -7 29 2
4.81818181818182
#include <iostream>using namespace std;int main(){ float mas[9]={-5,-1,2,3,-1,6,1,-1}; float sum=0; bool a=false; int counter=0; for(int i=0;i<8;i++){ if(mas[i]>0&&!a){ a=true; i++; } if(a){ cout<<mas[i]<<endl; sum+=mas[i]; counter++; } } cout<<sum/counter<<endl; return 0;}