НА Python У вас есть с собой T (T вводится с клавиатуры) золотых монет.

Местные жители согласились продать вам припасы, но у них есть странный ритуал. Всего в деревне n (n вводится с клавиатуры) жителей, у каждого из них цена за килограмм припасов составляет определенное количество монет (число монет для каждого жителя вводится с клавиатуры и собирается в список).

Вы должны покупать припасы следующим образом:

Сначала покупаете 1 кг у первого жителя, потом идете ко второму, независимо от того, хватило ли денег, потом идете к третьему, и т.д. Как только обойдете всех жителей, идете снова к первому, потом ко второму и т.д.

Напишите программу, которая определит, сколько всего кг припасов вы можете купить по такому принципу.

Оптимизируйте программу, максимально снизив количество итераций в цикле

Нурсултан05072017 Нурсултан05072017    3   09.01.2021 12:43    11

Ответы
daqqwe daqqwe  12.02.2021 22:42

T = int(input())

lst = [int(input()) for i in range(int(input()))]

t1, kg = 0,0

while True:

   for i in lst:

       if (T-i) >= 0:

           T-=i; kg+=1

       else: t1 = 1

   if t1 == 1: break

print(kg)

Кажись так ~

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика