tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
На паскале. вводятся координаты
На паскале. вводятся координаты x, y для n точек. определите, сколько точек в круг радиуса r. сколько точек в кольцо с меньшим радиусом r1, большим r2.
gnbufa
1 26.07.2019 01:50
3
Ответы
lizaroma224
24.09.2020 18:59
Var x,y,R,R1,R2,rt:real;i,N,k,m :integer;begin
R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N);
for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);
if rt < R then k:= k + 1;
if (rt < R2) and (rt > R1) then m:= m + 1;
end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
emmadetes
16.10.2020 11:14
Что лишнее? Файл, фанс, фунт, факт. Принтер, плоттер, винчестер, наушники. Копирование, произношение, перемещение, удаление, модификация. Имя, расширение, библиотека, файл,...
Shkolnik12345678910
16.10.2020 11:15
решить буду благодарна(7 вариант)...
gayratjonxaxa
16.10.2020 11:23
С азбуки Морзе декодируй сообщение: _ _ | _ . _ _ | _ _ _ _ | _ . . _...
niklysov2015
16.10.2020 11:23
В государстве все монеты имеют нечетный номинал. Известно, что максимальный номинал монеты 81, всего в обиходе 41 различный номинал. Нумизмат Прохор собрал полную коллекцию...
ukharitonova
16.10.2020 11:22
Задача 2 В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&»....
Tori163
16.10.2020 11:22
быстро мне до 10 сдавать надо я понять не могу...
irkaveerova
16.10.2020 11:22
Скиньте соч по алгебре класс 1 четверть...
shapovalovalyubochka
27.08.2019 21:30
Для какого из узказанных згачений числа x истиннл высказывание (x 1)и(x 2) и(xне равно 3)...
Emil304
25.10.2020 22:12
очень нужна Яхык:Фортран Вводится одномерный вещественный массив фиксированной длины, состоящий из «N» элементов (конкретное значение N для каждого студента индивидуально...
yanashabanova1
25.10.2020 22:11
Ситуация «Вам на электронную почту пришло письмо по объявлению.Вам написали, что готовы внести предоплату наВашу карту, и попросили отправить ее номер иPIN-код».Как следует...
Популярные вопросы
What is the time by these clocks and watches? write 9sentences. example:...
1
Втреугольнике abc проведена медиана bm, на стороне ab взята точка k...
1
Каким глаголом можно продолжить ряд глаголов: молоть, пороть,нести,...
2
Look, ask and answer. 1. bread? 2. olive oil? 3. eggs? 4. cheese? 5....
1
1укажіть йони що утворюються при дисоціації ортофосфатної кислоти по...
2
Вставьте вместо точек подходящие по смыслу слова (паронимы) из скобок....
1
1.даны пробирки с растворами: а). сульфата натрия; б) хлорида натрия;...
1
Почему пушкин дал такую фамилию швабрину...
2
Нужин твір на тему професія моєї мами бухгалтер ! маму звати світлана...
1
1)cos(в квадрате) x+3sinx-3=0 2)3sin(в квадрате) x=2sinx*cosx+cos(в...
2
R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N);
for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);
if rt < R then k:= k + 1;
if (rt < R2) and (rt > R1) then m:= m + 1;
end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.