На паскале составить программу нахождения количества отрицательных элементов в заданном массиве из 10 действительных чисел

денис1134 денис1134    3   30.05.2019 19:00    3

Ответы
Стаилз2002 Стаилз2002  30.06.2020 21:58
Var a, i:integer;
var arrayx = array[0..10] of integer;   
begin 
arrayx[0] = -1;
arrayx[1] = 3;
arrayx[2] = 5;
arrayx[3] = -3;
arrayx[4] = -2;
arrayx[5] = -7;
arrayx[6] = 2;
arrayx[7] = 3;
arrayx[8] = -10;
arrayx[9] = 0;
for i := 1 to 10 do
begin
if (arrayx[i] < 0) a:= a + 1; 
end;
writeln("Отрицательных чисел: ", a);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Q666Princess666Q Q666Princess666Q  30.06.2020 21:58
Program test;
const n = 10;
var i,k:integer;
m: array[1..n] of integer;
begin
for i:=1 to n do
begin
write(' Введите [',i,'] член масива: ');
readln(m[i]);
end;
for i:=1 to n do if m[i]<0 then inc(k);
writeln('Количество чисел меньших нуля :',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика