написать программу в pascal, которая выводит числа из диапазона от 72 до 134, удовлетворяющие условиям: 1. вывести все чётные числа; 2. вывести числа, оканчивающиеся на "3"; 3. вывести числа, сумма цифр которых меньше 11.

Mifka15 Mifka15    2   11.01.2021 22:33    5

Ответы
MrVyacheslav228 MrVyacheslav228  10.02.2021 23:03

Код программы:

var i, sum, a:integer;

begin

 writeln('Четные числа:');

 for i:= 72 to 134 do begin

   if i mod 2 = 0 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, оканчивающиеся на "3":');

 for i:= 72 to 134 do begin

   if i mod 10 = 3 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, сумма цифр которых меньше 11:');

 for i:= 72 to 134 do begin

   a:= i;

   sum:= 0;

   while a <> 0 do begin

     sum := sum + a mod 10;

     a := a div 10;

   end;

   if sum < 11 then

     write(i, ' ');

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика