На паскале нужно решить 1.задано трехзначное число. составьте программу, с которой определите произведение кубов цифр этого числа. 2.задано трехзначное число. составьте программу, с которой определите , равняются ли в нем крайние числа.

Georgiy11111 Georgiy11111    2   13.08.2019 01:40    3

Ответы
Marattadjibov73 Marattadjibov73  04.10.2020 14:47

var
a,e,d,s,p: integer;
begin
p:=1;
writeln ('введи трехзначное число');
read (a);
e:= (a mod 10);
s:=(a div 100);
d:=s*100-e;
 p:=s*s*s*d*d*d*e*e*e;
 writeln ('произведение кубов цифр числа равно',p);
if e=s then writeln ('первая цифра числа равна последней')
  else
writeln ('первая цифра числа не равна последней');
end.


ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика