На одном из языков программирования (python, pascal, c, c++, c#, java) написать программу, которая бы вычисляла по введенным пользователем данным (четыре целых числа, соответствующих числу цветных шаров) информационный вес выпавшего шара каждого цвета. если введено число 0 шаров, то не выводить никакой информации об этом цвете. пример входных данных: компьютер: перед вами программа, которая умеет вычислять количество информации по выбранному наугад шарику из мешка. компьютер: введите число шаров белого цвета: юзер: 100 компьютер: введите число шаров чёрного цвета: юзер: 100 компьютер: введите число шаров синего цвета: юзер: 100 компьютер: введите число шаров красного цвета: юзер: 100 во фразе «выпал белый шар» содержится 2 бит(а) информации во фразе «выпал чёрный шар» содержится 2 бит(а) информации во фразе «выпал синий шар» содержится 2 бит(а) информации во фразе «выпал красный шар» содержится 2 бит(а) информации

chestnut3342 chestnut3342    3   29.09.2019 18:20    3

Ответы
5454540 5454540  09.10.2020 03:27

var k1,k2,k3,k4,k:integer;

begin

writeln('Перед вами программа, которая умеет вычислять количество информации');

writeln('по выбранному наугад шарику из мешка.');

writeln('Введите число шаров белого цвета:');

readln(k1);

writeln('Введите число шаров чёрного цвета:');

readln(k2);

writeln('Введите число шаров синего цвета:');

readln(k3);

writeln('Введите число шаров красного цвета:');

readln(k4);

k:=k1+k2+k3+k4;

if k1<>0 then

writeln('Во фразе «Выпал белый шар» содержится ',log2(k/k1):4:1,' бит(а) информации');

if k2<>0 then

writeln('Во фразе «Выпал чёрный шар» содержится ',log2(k/k2):4:1,' бит(а) информации');

if k3<>0 then

writeln('Во фразе «Выпал синий шар» содержится ',log2(k/k3):4:1,' бит(а) информации');

if k4<>0 then

writeln('Во фразе «Выпал красный шар» содержится ',log2(k/k4):4:1,' бит(а) информации');

end.

Пример:

Перед вами программа, которая умеет вычислять количество информации

по выбранному наугад шарику из мешка.

Введите число шаров белого цвета:

100

Введите число шаров чёрного цвета:

0

Введите число шаров синего цвета:

200

Введите число шаров красного цвета:

100

Во фразе «Выпал белый шар» содержится  2.0 бит(а) информации

Во фразе «Выпал синий шар» содержится  1.0 бит(а) информации

Во фразе «Выпал красный шар» содержится  2.0 бит(а) информации

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика