На c++ напишите программу, которая находит все различные цифры в символьной строке. формат входных данных на вход программе подаётся символьная строка. формат выходных данных программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. если в строке нет цифр, нужно вывести слово 'no'.

peindragneel11 peindragneel11    3   15.09.2019 18:40    34

Ответы
rimakarapetyan12 rimakarapetyan12  07.10.2020 18:00
// Если захочешь перенести массив из глобальных переменных, не забудь обнулить его

#include <bits/stdc++.h>

using namespace std;

bool a[10];
int main()
{
  string s;
  cin >> s;
  for (int i = 0 ; i < s.length(); ++i)
    if (isdigit(s[i]))
        {
          int ind = s[i]-'0';
          a[ind] = true;
        }
  bool fl = false;
  for (int i = 0; i < 10; ++i)
    if (a[i])
      {
        fl = true;
        cout << i << ' ';
      }
if (!fl)
        cout << "NO";

}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика