На ! 1. написать программу которая будет выводить сумму четных цифр(пока не введете 0). 2.программа выводит количество четных цифр. 3.программу которая будет выводить произведение введенных чисел пока не будет введен 0.

Roblox2017 Roblox2017    1   12.09.2019 00:10    2

Ответы
ирт3 ирт3  07.10.2020 08:38
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Sum)
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
2708

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Count)
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
5

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Aggregate(Biginteger(1),(x,y)->x*y))
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
-775118121479521866390147967800000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика