Много ! напишите программу как в паскале для :
1. с клавиатуры вводят координаты точки, не лежащей на координатных осях ох и oy. определить номер координатной четверти, в которой находится данная точка.
2. с клавиатуры вводятся четыре числа. найти сумму наибольшего с наименьшим.

Дания29 Дания29    1   07.11.2019 18:08    4

Ответы
принцесса212 принцесса212  10.10.2020 11:54

Объяснение:

1) program abc;

var x,y:real;

begin

readln(x,y);

if (x>0) then begin // проверка по x

 if (y>0) then  

  writeln('1th'); // попадает в первую

 if (y<0) then

   writeln('4th'); // проверка в четвёртую

end

else begin

 if (y>0) then  

  writeln('2nd'); // попадает во вторую

 if (y<0) then

  writeln('3th'); // попадает в третью

end;

end.

2)

program abc;

var A:array [1..4] of real; // ввод массива из четырёх чисел

i,max,min:shortint; // i - цикл, max - индекс максимального значения, min - минимального

s:real; // сумма

begin

readln(a[1]); // ввод первого значения

max:=1;

min:=1; // считаем что первое значение и минимум и максимум

for i:=2 to 4 do

 begin

  readln(A[i]); // ввод массива

  if A[i]>a[max] then // Если данный элемент больше максимального

   max:=i; // То записываем индекс этого элемента

 if A[i]<A[min] then // аналогично с минимумом

 min:=i;

 end;

s:=A[max]+a[min]; // суммируем и выводим

write(s);

 end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика