Мне с паскале) опишите процедуру поиска наибольшего и наименьшего элемента массива. с этой процедуры составить программу, которая определяет ли наибольший и наименьший элементы двух массивов a[1..n], b[1..n].

Анамтасия727 Анамтасия727    2   15.06.2019 20:30    1

Ответы
hdhushehsuu hdhushehsuu  12.07.2020 21:06
Program gt;
var n,i,max,max2,min,min2:integer;
a,b:array[1..100]of integer;
procedure proverka(a:array[1..100]of integer;var max,min:integer);
begin
max:=a[1];min:=a[1];
for i:=1 to n do
begin
if(a[i]>max)then max:=a[i];
if(a[i]<min)then min:=a[i];
end;
end;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
read(b[i]);
proverka(a,max,min);
proverka(b,max2,min2);
if  (max = max2) and (min = min2) then writeln('YES')else
writeln('NO');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика