tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Массив состоит из 15 случайных
Массив состоит из 15 случайных чисел,получить новый массив,в котором элементы первого массива имеют противоположный знак.в полученном массиве удвоить элементы,которые меньше -50.
ПУПКИН228
2 19.07.2019 06:10
0
Ответы
sweet690
03.10.2020 07:40
Program programma;
uses crt;
var i: integer;
a:array [1..15] of integer;
begin clrscr;
randomize;
for i:=1 to 15 do
a[i]:=random(200)-100;
writeln('Массив:');
for i:=1 to 15 do
write(a[i]:5);
for i:=1 to 15 do
begin
a[i]:=-a[i];
if (a[i]<-50) then a[i]:=a[i]*2;
end;
writeln;
writeln;
writeln('Новый массив:');
for i:=1 to 15 do
write(a[i]:5);
READLN;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
шпион223709
03.03.2021 13:47
Что выведет программа? a = 711; b = 711; print(a-b)...
shapuk
03.03.2021 13:48
Установите соответствие между переменной и типа данных a) Int 1. X = 56.2b) Float 2. X = true c) Str 3. X = 562e) Bool 4. X = 《Моя школа》...
olesyakondakova
03.03.2021 13:48
Какое действие показано фото?...
Даняша09
02.09.2019 22:40
Написать программы в паскале. 1.сформировать 25 случайных вещественных чисел со значениями в интервале от 3700 до 9000, выделив в дробной части три разряда. поменять...
крузейро
02.09.2019 22:40
Нужно составить программу, которая на входе должна получать последовательность цифр, после чего программа показывает цифру, порядковый номер которой ввел пользователь....
mprodeus99p0812l
02.09.2019 22:40
Написать программу вычисления покупки с учётом скидки 10%. скидка предоставляется, если сумма покупки больше 1000 руб....
ЭллиВейн
24.04.2020 23:46
Мне нужно чтобы зарегистрировался!Кто может...
wiwhha
24.04.2020 17:13
Напишите класс Голубь (Pigeon), экземпляр p которого инициализируется с аргументами: имя (строка), дальность полёта и грузоподъёмность (целые числа). Класс реализует...
ubbdfqhdu
09.04.2019 21:57
60 ! растровые изображения формируются из: 1) точек различного цвета (пикселей); 2) линий; 3) графических объектов; 4) цветовой палитры. 2. достоинством векторных...
лола269
09.04.2019 21:45
Write ( h = , h); для h=5 на экране будет ...
Популярные вопросы
1. У склянці вміщується близько 2 моль солі. Обчисліть число молекул...
1
Найдите меньший корень уравнения 12х ^2 = 6 – х. Решите...
1
Русский язык 7классЛатыженская упр 491 ...
1
Какая потребность скрыта в пиромиде? Начинается на л...
3
Знайдіть абсолютну величину вектора а (-7:-24)...
3
Скоротіть дрібЗа2 O6)За°ь3464...
1
Как решается этот пример 180×3-80×3...
3
Найти общее решение (общий интеграл) дифференциального уравнения...
3
Алюміній оксид масою 20, 4 г повністю прореагував з хлоридною...
3
який заряд розміщений в точці електричного поля напруженість у...
2
uses crt;
var i: integer;
a:array [1..15] of integer;
begin clrscr;
randomize;
for i:=1 to 15 do
a[i]:=random(200)-100;
writeln('Массив:');
for i:=1 to 15 do
write(a[i]:5);
for i:=1 to 15 do
begin
a[i]:=-a[i];
if (a[i]<-50) then a[i]:=a[i]*2;
end;
writeln;
writeln;
writeln('Новый массив:');
for i:=1 to 15 do
write(a[i]:5);
READLN;
end.