Любую на выборнадо написать программу на любом языке программирования задано n - количество целых чисел. найти сумму нечетных кратных 5, если таких чисел нет сумму считать равной 0. задано n - количество натуральных чисел. найти максимальный среди трехзначных нечетных. гарантируется, что хотя бы одно такое число в последовательности присутствует.задано n - количество целых чисел. найти произведение максимального и минимального положительных чисел данной последовательности. гарантируется, что в последовательности присутствует минимум два положительных числа.задано n - количество натуральных чисел. найти наибольшую разницу между двумя рядом стоящими элементами. гарантируется, что элементов не меньше двух.

aliskaiii aliskaiii    3   19.04.2019 20:16    4

Ответы
NekkeR8821 NekkeR8821  08.06.2020 01:52

Объяснение:

На выбор - первая)

var

 n:integer;

 a:array[1..1000] of integer;  

 i:integer;

 sum:integer;

begin

 readln(n);

 

 for i:=1 to n do

   readln(a[i]);

 

 sum:=0;

 for i:=1 to n do

   if (((a[i] mod 2)<>0) and ((a[i] mod 5) = 0)) then sum:=sum + a[i];

 

 writeln(sum);

 

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика