tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Лёгкая по информатике
Лёгкая по информатике паскаль. по заданному числу x и целому n вычислить x^n используя цикл .
tyrone12
3 05.09.2019 14:00
6
Ответы
дeд
06.10.2020 19:25
Var x,xn:real; n,i:integer;
begin
readln(x,n);
xn:=1; i:=0;
repeat
i:=i+1;
xn:=xn*x;
until i=abs(n);
if n<0 then xn:=1/xn;
writeln(x:3:1,'^',n,' = ',xn:6:4);
end.
Пример:
2 -3
2.0^-3 = 0.1250
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
рашад10
13.07.2019 23:00
Решить по информатике..буду сколько секунд потребуется модему, сообщение со скоростью 28800 бит/сек, чтобы доверить цветное изображение размером 640*480 пикселей, при условии,...
staroverovandr
01.09.2019 18:30
Укажите вид графики,соответствующий описанию: в памяти компьютера сохраняется информация о цвете каждого входящего в неё пикселя: 1) растровая графика 2)векторная графика...
lovelovelove11
20.11.2020 11:58
Практична робота №2. Уведення, редагування та форматування даних у середовищі табличного процесора . (Бали: 12) Завдання 1. Сонячна система ( ів) 1. Запустіть табличний...
илья5310
06.03.2020 03:06
Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру. Входные данные Входная строка содержит неотрицательное число...
njjk1
30.07.2019 07:20
Количество цифр, используемых для записи числа в данной системе счисления, называют: 1. кодом 2. разрядом 3. основанием 4, коэффициентом...
mygalmaksim
30.07.2019 07:10
Чем должен быть оборудован компьютер для работы с мультимедийными продуктами...
pamagiteplease
30.07.2019 07:00
Задан массив k(n). и отрицательные элементы массива заменить на их квадраты. вывести их индексы и новые значения....
Milana29012000
30.07.2019 07:00
Заполнить массив a(21) случайными числами в диапазоне от -1 до 17. выведите его на экран. pascal abc 9 класс...
Аннасherry
30.07.2019 07:00
Нужен простой реферат по физкультуре на тему что такое физкультура?...
mandarin50
30.07.2019 07:00
Дано 2 треугольника. координаты вершин с клавиатуры в программе должно быть первая процедура, вторая функция.в процедуре должно считать стороны треугольников(по формуле...
Популярные вопросы
На фотографии изображен процесс образования тени от булавки. Как изменятся...
1
Выделите частицы в треугольник, подпишите разряд.А с сами ли (частица,...
2
Северные олени, обитающие в тундре, питаются около десяти месяцев в...
2
К одному семейству принадлежат:лилия и фасолькапуста и редисрожь и подсолнечникяблоня...
1
зделать контрольную роботу...
2
В каких словах количество букв и звуков совпадает маяк солнце шель бульон...
1
По чтению план гадкий утёнок план 1.Рождение утёнок. 2.Отличие от других....
1
Побудуйте графік функції 4х+у-3=0...
1
Андрійко прочитав на 20 сторінок менше, ніж Марійка. Скільки прочитав...
1
Из генеральной совокупности извлечена выборка объема n=50.xi 1 2 3 4ni...
3
begin
readln(x,n);
xn:=1; i:=0;
repeat
i:=i+1;
xn:=xn*x;
until i=abs(n);
if n<0 then xn:=1/xn;
writeln(x:3:1,'^',n,' = ',xn:6:4);
end.
Пример:
2 -3
2.0^-3 = 0.1250