tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Кто шарит в информатике
Кто шарит в информатике .. нужно разработать программу в pascal для решения уравнения вида {a}^{x} = bax=b нужно составить модель, блок-схему и программу хелп
ми34ми56
3 27.09.2019 00:01
1
Ответы
участник78
08.10.2020 21:25
Показательное уравнение решается логарифмом, линейное - делением
x=ln (b)/ln (a) первый случай
x=b/a второй случай
program test;
uses crt;
var a, b,x: real;
begin
clrscr;
repeat
readln ('Введите значение коэффициентов ',a,b)
until a>0 and b>0;
x:=ln (b)/ln (a);
writeln ('решение показательного уравнения ',x);
x:=b/a;
writeln ('решение линейного уравнения ',x);
readkey;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
AlisaLisa005
29.05.2019 10:10
Большая,круглая,вращается вокруг земли...
draganmarta
29.05.2019 10:10
Составить программу для вычисления f=c+(a+b)/(a*b+1) a-наименьший элемент массива; в-количество отрицательных элементов массива; с-количество элементов массива, меньших...
mashabest19861
23.05.2021 16:02
Логическая функция F задаётся выражением ¬a Ú (b Ù ¬c). Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных a, b, c. В ответе...
netesa0202
23.05.2021 16:00
(жаль тут материца нельзя меня соседи бесят они моргена на колонках слушают((()...
derkioptu
23.08.2019 02:40
Создать программу, чтобы нашло максимальное отрицательное число кратное 2. заранее...
кудряшёв
23.08.2019 02:40
1. написать программу и блоксхему со степенью с циклом с постусловием. 2. написать программу и блоксхему, которая вычисляет сумму числового ряда от а до в...
Ananasik3333
07.06.2019 20:40
Переписать, исправив ошибки в программе: program a; var 2b, a1: int; begin read (a1) 2b : = a1 + 5; a1 : = 2b : 2; write (2b, a1) end....
Никита2OO7
21.02.2022 00:57
Дана матрица размера MxN. Найти минимальный среди максимальных элементов ее столбцов. C++...
gurova07
21.02.2022 01:15
В каких случаях черепаха будет выходить за пределы экрана? Возможны несколько правильных вариантов ответа.гото (0,208)гото (50, -150)гото (500,10)гото (112, -35)...
PomidorkaX3
21.02.2022 01:24
ОДНО ЗАДАНИЕ Кто хорошо знает информатику? Буду очень благодарен...
Популярные вопросы
Рассчитать ускорение тела с массой 2кг действует сила изменяющейся...
1
Коли утворилася кримське ханство як незалежна держава а. у 60х.рр.14ст...
3
На координатной плоскости отметьте точки, последовательно соединяя...
2
Вычислите в столбик! 1826*24 2587*77 186964*38...
1
Пословицы без труда не выловишь и рыбки из пруда 20...
3
Накресли відрізок довжиною 9 см. на відстані 5 см від початку відрізка...
3
15 .нужно решить все кроме последнего и 1...
1
для квадратичной функции у = 2 х^2+7x -3 найти y(-3) 2. дана функция...
3
Как изменится значение произведения, если: а)один множитель увеличить...
3
Что обазначает последная фраза в рассказе фотография на которой меня...
3
x=ln (b)/ln (a) первый случай
x=b/a второй случай
program test;
uses crt;
var a, b,x: real;
begin
clrscr;
repeat
readln ('Введите значение коэффициентов ',a,b)
until a>0 and b>0;
x:=ln (b)/ln (a);
writeln ('решение показательного уравнения ',x);
x:=b/a;
writeln ('решение линейного уравнения ',x);
readkey;
end.