Кто понимает паскаль, обращаюсь к вам! нужна ваша ! составьте программу, которая выводит все символы до первого многоточия и программу, которая заменяет каждое многоточие точкой и каждый пробел точкой.

дара23 дара23    3   15.08.2019 09:30    5

Ответы
ekaterinaf79 ekaterinaf79  09.08.2020 11:48
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  var p:=Pos('...',s);
  if p>0 then Writeln(Copy(s,1,p-1))
end.

Пример
> Это такая... тестовая... строка
Это такая

// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  Writeln(s.Replace('...','.').Replace(' ','.'))
end.

Пример
> Это такая... тестовая строка, надуманная...
Это.такая..тестовая.строка,.надуманная.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика