пожайлуста
​Напишите программу, которая в последовательности натуральных чисел:

а) определяет максимальное число, оканчивающееся на 5;

б) считает количество четных чисел.
Программа получает на вход кoличество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 5, и хотя бы одно четное. Количество чисел не превышает 100. Введённые числа не превышают 10 000. Программа должна вывести два числа — максимально число, оканчивающееся на 5, и количество четных чисел.

юлия1868 юлия1868    1   06.05.2020 15:21    11

Ответы
id95874775 id95874775  14.10.2020 08:43

Ну вроде так:

var n, i, m, kol, chislo: integer;

begin

write('Введите количество чисел ');

read(kol);

for i:=1 to kol do

begin

write('Введите число ');

read(chislo);

if (chislo mod 2 = 0) then n:=n+1;

if (chislo mod 10 = 5) and (chislo > m) then m:=chislo;

end;

write('Количество четных: ',n,' Самое большое оканчивающееся на 5: ',m);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика