Как в c++ написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. я пишу, вроде всё правильно делаю, но программа выдает: "hello, 0", чтобы я не вводила. #include ; using namespace std; int main() { int name; cout < < "what is your name? "; cin > > name; cout < < "hello," < < name< < endl; return 0; }

arutik5 arutik5    3   26.09.2019 16:10    4

Ответы
89528849556keyz 89528849556keyz  08.10.2020 20:34
По порядку:
1) Ты забыл подключить библиотеку <iostream> (надо было наприсать
#include <iostream>)
2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C++ - это string (Для ее использования необходимо ее подключить - #include <string>)

Итого
#include <iostream>
#include <string>

using namespace std;

int main() {
string name;
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name<< endl;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
ayaulymmuratbekova ayaulymmuratbekova  08.10.2020 20:34
Достаточно массива char str[10] и не нужно ничего лишнего подключать, прежде чем переходить к <string> из С++, стоить ознакомится со Си строками, тк <string> это только удобная обертка
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика