Как составить программу подсчета количеству делений введённого числа на 12 пока оно не станет меньше 10

PilkaPie PilkaPie    1   22.05.2019 18:00    4

Ответы
mashenkalarchenko mashenkalarchenko  18.06.2020 07:40
Pascal:
var count:integer;
     n:real; 
begin
  write ('N = ');
  readln(n);
  count:=0;
  while n>=10 do
    begin
      n:=n/12;
      inc(count);
    end;
  write ('Kol-vo: ',count);
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
   float n;
   int count = 0;
   cout <<"N = ";
   cin >>n;
   while (n>=10)
   {
      n/=12;
      ++count; 
   }
  cout <<"Kol-vo: " <<count <<endl;
  return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика