Информатика. составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10 и находит сумму минимального и максимального элементов массива

skirtachmaksim skirtachmaksim    2   14.08.2019 05:50    2

Ответы
Tema20181234 Tema20181234  04.10.2020 18:08
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,0,10); a.Println;
  Writeln(a.Max+a.Min)
end.

Пример
6 5 4 7 5 8 8 10 0 2
10
ПОКАЗАТЬ ОТВЕТЫ
Учитель1236 Учитель1236  04.10.2020 18:08
Си.

#include <stdio.h>
#include <stdlib.h>

void main( void )
{
   int A[10], max = A[0], min = A[0], i;

  for (i = 0; i < 10; i++)
  {
    A[i] = rand() / RAND_MAX * 10;
    if (A[i] < min)
      min = A[i];
    if (A[i] > max)
      max = A[i];
  } 
}

printf("Sum of min & max: %i", (max + min));
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика